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1. Introduction to MFMS
This is a comprehensive guide to using the Multimedia Fieldwork Management System
(MFMS) for the storage and distribution of collections of digital content. This platform
facilitates the import, bulk editing, metadata tagging, and the representation of fieldwork.
This instructional guide will take you through all the steps required to use this tool, starting
from the field and ending with a fully functioning webpage for presenting your multimedia
collections.

1a. Materials Needed
Use of the MFMS requires the following tools:
An operational WordPress website
Evernote
Metadata Tag Code
Media Export Code Bundle
JWPlayer License Key
WordPress Plug-in: Photo Gallery (v. 1.3.41)
WordPress Plug-in: Video Gallery (v. 2.3)
WordPress Plug-in: Media Library Assistant (v. 2.51)
WordPress Plug-in: Download Media Library (v. 0.2.1)
WordPress Plug-in: Custom Media Search (v.1)
WordPress Plug-in: MLA Custom Search (v.1)
WordPress Plug-in: EvernoteSync (v. 1.2.16) OR an IFTTT account
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Additionally, if you are on a Windows PC Computer:
Python

1b. Definitions
Shortcode: A shortcode is a WordPress-specific code that lets you do simple things with
very little effort. Shortcodes can embed files or create objects that would normally require
more complex code. Shortcode = shortcut.
Plugins: Plugins are ways to extend and add to functionality that already exists in
WordPress. Plugins offer custom functions and features for your website.
Tag: Tags are a keyword or term assigned to a piece of information (in our case, Evernote
Notes) that help describe an item and allow it to be found by browsing or searching.
PHP: PHP is an open-source scripting language that WordPress uses to function.

1c. Disclaimer
This manual was written using WordPress version 4.7.3. The plugins used in the manual
have been tested and were found to be compatible with this version of WordPress. We
cannot guarantee that future versions of the plugins will be compatible with this version of
WordPress, nor can we guarantee that future versions of WordPress will work with these
versions of the plugins. Take precautions before performing major WordPress system
updates.
To download the plugin versions tested in this manual, visit:
http://socialanthropology.org/downloads/
Additionally, the Evernote Sync plugin requires your host to be using version 7 of PHP
(PHP7). If your host is not yet using PHP7, it is probable that they will be upgrading within
the next year. However, any website using earlier versions of PHP7 will use an alternative
method of connecting Evernote and WordPress, through a website called If This, Then That
(IFTTT).
This is something that your computer support or host will be able to inform you of.
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1d. About Us
This suite of tools was developed by Mark Turin (Project Lead) and Bridget Chase (Head
Developer), with financial support from Sichuan University and the Cambridge Rivers
Project.
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2. Set-Up
Setting up your WordPress website
We start this tutorial with the necessary set up for your WordPress website. We will work
from the assumption that you have already created a WordPress website, and have
administrative privileges so that you can download a few plugins and add some basic code to
make your website function as a MFMS.

2a. Plugins
To start, you need to download and install the following plugins.
To download the plugin versions tested in this manual, visit:
http://socialanthropology.org/downloads/
We have bundled the required plugins and tools on our website in a downloadable .zip file.
You are also able to download these files individually. Once downloaded, you can upload
the .zip files to your WordPress website (as explained below).
Note that downloading them via the WordPress links below will give you the newest versions
of the plugins, which we can not guarantee will be compatible with the MFMS system.
To download plugins via WordPress, click the links below. To install, go to your WordPress
dashboard and click on Plugins > Add New, and then search for the name of the plugin
within the Search plugins… Then, click Install Now, and Activate.
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The first is Photo Gallery and can be found here:
http://socialanthropology.org/downloads

The second is Video Gallery and can be found here:
http://socialanthropology.org/downloads

The third is Media Library Assistant and can be found here:
http://socialanthropology.org/downloads
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The fourth is Download Media Library and can be found here:
http://socialanthropology.org/downloads

The fifth is Custom Media Search and can be found here:
http://socialanthropology.org/downloads
The sixth is MLA Custom Search and can be found here:
http://socialanthropology.org/downloads
The seventh is Evernote Sync and can be found here:
http://socialanthropology.org/downloads
(If your website host doesn’t use PHP7, then skip this download and follow the instructions
in Section 2F of the manual)

If you have downloaded the .zip files from the our website, you need to manually upload
them to WordPress.
1. Click to download the .zip file. Depending on the browser you are using, it may unzip the
contents of the file. If you use the browser Google Chrome, this will not happen. If it does
unzip, right click on the file and click Compass [file name] to turn it back into a .zip
2. On your WordPress dashboard, click Plugins > Add New
3. Click Upload Plugin
4. Click Choose File and select your .zip
5. Click Install Now
6. Click Activate
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After downloading all of the plugins, your Plugin page will look like:

2b. Evernote
Download the Evernote application here: https://evernote.com/download/

2c. Metadata Search Box
One of the features that makes the MFMS work is a custom search box on your WordPress
website, specifically for metadata. While a normal search box will look for content within
pages, the Metadata Search Box will look for content (metadata) within a media item. To add
this Metadata Search Box on your pages:
1. Insert this shortcode into whatever page of your website that you would like the Metadata
Search Box to appear. It will appear at the top of the page:
[sj_advanced_media_search]
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2d. Metadata Export Code
Exporting the custom metadata information attached to media files requires the use of a
simple Python code bundle, which can be downloaded here:
http://socialanthropology.org/downloads/
NOTE: It is not necessary to download this code unless you are ready to export
your media content and associated metadata.

2e. Python
If you are on a Windows PC, you will need to download Python in order to extract the
metadata from the media content (see Section 7e):
https://www.python.org/downloads/windows/

2f. If This, Then That (IFTTT)
If your website host uses a version of PHP earlier than PHP7, the Evernote Sync plugin will
not be compatible with your website. The web service IFTTT is an alternative method of
connecting your Evernote account with your WordPress account (which you will need to do
for Section 3: Fieldwork). To create an IFTTT account, go to: https://ifttt.com/join
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3. Fieldwork
Starting in the field
We start this tutorial in the field, as if a fieldworker has just taken notes, an image, video, or
made an audio recording that they wish to upload onto the WordPress server.
If you are using Evernote Sync (your website host uses PHP7), continue to
Section 3a.
If you are using IFTTT (your website host does not use PHP7), continue to
Section 3b.

3a. Creating an Evernote Account and Linking it to WordPress via
Evernote Sync
2. Open the Evernote application and log in.
3. Go to https://www.evernote.com/api/DeveloperToken.action to find your
Evernote account Developer Token.

4. Create a developer token, and copy it to your clipboard.
5. Log into your WordPress website and click on Settings > EvernoteSync
on the sidebar.
6. Paste your Developer Token into the box that says Developer Token.
7. Change the Platform to Evernote.
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8. In Tag for Sync, type a specific tag (the name of your fieldwork group name, for
example) then click Save Options. This tag is used to link your Evernote Notes with
your WordPress site and remains the same every time you need to use a tag.

9. You will see Save Success at the top of the screen, which verifies the completion of this
section.

3b. Creating an Evernote Account and Linking it to WordPress via
IFTTT
If you have just completed Section 3a, it is not necessary to do this step as well.
Continue to Section 3c.

1. Log in to IFTTT here https://ifttt.com
2. Click My Applets.
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3. Click New Applet.

4. Click on the +this.

5. Type in Evernote and click on the Evernote icon.

6. Click the Connect button.

7. In the new window, sign in to your Evernote account in order to authorize IFTTT to
connect with it.
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8. Click the Authorize button.
9. Click on the Add a Specific Tag to Note trigger.

10. Type a specific tag (the name of your fieldwork group name, for example) then click
Create Trigger. This tag is used to link your Evernote Notes with your WordPress site
and remains the same every time you need to use a
tag.

11. Click on the +that.

12. Type in WordPress and click on the WordPress icon.

13. Click the Connect button.
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14. In the new window, sign in to your WordPress
account in order to authorize IFTTT to connect with
it.

15. Click on the Authorize button.
16.Click on the Create a Post trigger.
17. Under Post Status, select Save as Draft, then click
Create Action.

18. Now your Evernote and WordPress accounts are linked.
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3c. Creating a Notebook and a Note
1. Open your Evernote account, either through the web or through the app itself.
2. On a Mac, click File, New Notebook > Synchronized Notebook. On a PC, click File
> New Notebook (and select Private).

3. Give your notebook a name, as in Fieldwork in Chengdu, August 2017.
4. Click New Note to present a new, blank Note. Make sure that your note is located in the
notebook you’ve just created.

3d. Composing a Note and Syncing it to WordPress
1. Give your new Note a specific name, as in Interview with Mr. Lee.
2. Click the paperclip icon in the toolbar to add images, audio, video or other files. To add
text, just type in the open text box. You can also add audio
directly from the mobile app by clicking the microphone
icon. Don’t worry about saving, it saves automatically.
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3. In the toolbar, where it says click to add tags, type in the same tag you used in 3a. #7 or
3b. #10 (for example, your fieldwork group name). This is what allows your Evernote and
WordPress to sync.
4. Click the Sync icon at the top of the page to sync your account immediately
so that your Note shows up on WordPress.

5. You’ve now created and sent a new Note to your WordPress website.
So, for example, we have created a Note with the title Example Note, the tag
himalaya.center, and with the following picture included. We click Sync for it to sync to
the WordPress site.

3e. Checking WordPress for your Synced Content
1. Go to your WordPress website and click Posts on the WordPress sidebar.
2. Your Note appears as a Post in the list of Posts on this page, with the
word Draft next to it (meaning that it is not live and viewable to people
who visit your website).
3. If you click on the Post, it will look exactly like your Note did, including
the content that you added.
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4. If you added multimedia content in your Post (i.e images, audio,
videos - anything other than basic text), click on Media on the
WordPress sidebar.
5. You will see that this content has been added to your Media Library
(media can be used in any part of your website).

TIPS:
If you plan on uploading and syncing large files (such as videos), or a large number of
files, consider upgrading to Evernote Plus or Evernote Premium, which will allow you to
import bigger file sizes.
Learn more about the benefits of Evernote Plus here:
https://evernote.com/upgrade/?tier=plus
and Evernote Premium here: https://evernote.com/upgrade/?tier=premium
Title the multimedia content with appropriate/easy to search names before importing it
into Evernote and syncing it to WordPress. The file name will become the name of the
multimedia file on WordPress, and while this can be changed easily, it will save you time
if you name your files properly beforehand.
Learn more about Evernote’s many features here:
https://evernote.com/evernote/guide
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4. Metadata
Adding metadata to your multimedia content
4a. Using Basic Media Library Features
Now that you have added multimedia content into your WordPress Media
Library, it is time to add the necessary metadata.
1. Click on Media to go into your Media Library.
2. Click on the content that you want to add metadata to (in our example, we
use the image that we uploaded via Evernote earlier).

3. A page will pop up with the image shown, its title
(which can be changed), and some empty fields that
you can fill in: Caption, Alternative Text, and
Description.
Let’s say that you want more specific fields, as you need to
input metadata information about, for example, the
photographer, location, date taken, etc.
This is where our Metadata Tag Code comes in. The
Metadata Tag Code will allow you to customize the fields
shown in the WordPress Media Library, allowing you to
add new fields as needed.
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4b. Setting up
1. Click on Settings > Media Library Assistant.
2. Scroll down until you see the Taxonomy Support section.
3. Verify that the boxes under Support, Inline Edit, and Term Search
are all unchecked.

4. Scroll down until you see the Admin Menu Options section.
5. Verify that the box next to Display Media/Library is unchecked.

6. Click Save Changes.

4c. Adding custom metadata fields
1. Click on Custom Fields at the top of the page.

2. Scroll down until you see Add a new Field and Mapping Rule.
3. Fill in new Field Title with the name of the metadata category you want to add. For
example, Location.
4. Set Data Source to None, set Existing Text to Replace, set Format to Native, and check
the MLA Column, Quick Edit, and Bulk Edit columns.
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5. Click Add Field.

4d. Filling in custom metadata for a piece of multimedia content
1. Click Media on the sidebar.
2. Click Screen Options on the top right-hand side of the page, then
check off the boxes next to your newly added custom metadata fields
so that they appear on the editing screen. For example, if you added
Location as a metadata field, you will see a box titled Location which
you should click.

3. Click Apply.
4. To edit metadata fields for one individual piece of content, find the
content you want and click Edit.
5. An individual page will appear for that piece of content. Scroll down
until you see your Custom Fields.
6. Under Name, fill in the box with the metadata category that you created in 4c. Under
Value, fill in the box with metadata content.
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7. Click Update.

4e. Filling in custom metadata for multiple multimedia items
1. Click Media on the sidebar.
2. On the left-hand side of the page, click on the boxes next to any media
items you want to add the same metadata to.
3. Click Edit under Bulk Actions to bulk edit fields.
4. Click Apply.

5. Fill in whichever metadata fields you want all of your selected media files to have the
same information for. For example, we have selected all of the flags we have in our media
library. For the Collection metadata field, we will use the word Flags.
6. When you’re ready, click Update.
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5. Creating Image Galleries
Making images viewable on your website
Once you have enough content in your WordPress Media Library, this is how to create a
gallery for displaying it live on your website.

5a. Setting up Photo Gallery
1. Click the Photo Gallery > Options in the sidebar.
2. Check Yes next to Import from Media Library.

3. Click Save.

5b. Creating an Image Gallery
1. Click the Photo Gallery plugin on the sidebar.
2. Click the Add New button at the top of the
page to create a new Image Gallery.
3. Fill in the fields at the top of the page with information about
your Gallery.

Name your Gallery something specific to the collection (i.e, if your Gallery is filled with
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images of flags, name it Flags). The slug is the keyword that you use to embed the
Gallery onto a page of your website (it functions similarly to a tag). Make it specific to the
collection (in this case, flags would be a good slug). Write a short description for the
Gallery.
4. Once you’ve filled in the information above, click the Save button in
the top right corner.
5. Click on the name of your new Gallery.
6. Scrolling down, there is a place to add images to your Gallery.

7. Click the Add Images button, and a window will open.
8. Click the Media Library button on the toolbar to show all of the files in your WordPress
Media Library.

9. Hold down the control key (if on a PC) or the command key (if on a Mac) on the
keyboard and select all of the images you want to import into the Photo Gallery plugin.

10.Click Import selected images.
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11. The previous window will re-appear, with your newly imported images available to be

added to the Gallery. Hold down the control key (if on a PC) or the command key (if on
a Mac) and select all of the images you wish to include in this Gallery.

12.Click Add selected images to gallery.
13. You will now see all of your images available in
your Gallery. You can reorder them using the arrows on the left hand side, give them a
new title, add a description (which will appear in some galleries, depending on the theme
used: see 5b. #4), or delete images by clicking on the trash can icon.

14. Now that you’ve added images to your gallery, click on the Preview Image icon to select
an image to represent the Gallery.
15. Click Save.
www.socialanthropology.org

26

5c. Generating a Shortcode
Now that you have created a Gallery, it is time to customize its look and embed it into a page
of your website.
1. Click on Photo Gallery > Generate Shortcode.
2. A page with many customizable features will open up.

There are a number of different things that you can do to customize your Gallery. You can
read more about these in the Tips section of this chapter.
The basic steps you need to take are:
3. Select the Gallery you want to use in the Gallery field.

4. Select the type of Gallery you want to have at the top of the screen (this will determine
how your Gallery appears on your web page).

5. Click the Generate button at the bottom of the page.
6. Copy the code given in the Shortcode field.
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5d. Embedding a Shortcode into a Page
Now that you’ve created your Gallery, customized its appearance and created its shortcode,
you need to put it on a web page so that people viewing your website can see it. If you already
have a page on your website set up and ready for your Gallery, skip to #3.

1. Click Pages > Add New on the sidebar.
2. A blank page will appear. Fill in the title and whatever other content is needed for the
page. For our example page, the title is Flags, and there is some text describing the page.
3. Paste your shortcode wherever you want the Gallery to appear on the page (in between
text, at the top/bottom, etc.).
4. Click the Preview button on the right to preview how your Gallery is
going to look on your page. It will open up a new window to show you.
Every page will look different, depending on how it is customized.

5. Return to the previous window where you can edit your page. If you like the way the
Gallery/page looks and you’re ready to make it public on your website, click the Publish
button. If not, you can always click the Save Draft button to save your progress and
come back later.
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TIPS:
Photo Gallery is a plug-in with a large number of possibilities available to create
interesting and fully-functioning galleries. Click here to read more about Photo Gallery
and all of its features:
https://web-dorado.com/wordpress-gallery/installing.html
For even more Photo Gallery customizability options, we would recommend upgrading to
Photo Gallery Pro. More information here:
https://web-dorado.com/products/wordpress-photo-gallery-plugin.html
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6. Creating Video Galleries
Making your videos viewable on your website
If you have videos that you wish to display on your website, this is how to do so. Since
YouTube videos can not be played in China, we use a plugin to embed videos that you’ve
uploaded into your WordPress Media Library.
In order to build a Video Gallery, you will have to have added video content to the Media
section of the website. If you haven’t already uploaded video content, do so before beginning
this section.

6a. Setting up Video Gallery
1. Before using the Video Gallery, you need to get a JWPlayer license key. JWPlayer is a
the program that allows for video to display on your website. Go to this link:
https://www.jwplayer.com/sign-up/.
2. Enter an email address and click Get JWPlayer Free.
3. Once you’ve made an account and logged in, you’ll see the JWPlayer homepage,
with a blue sidebar. Click Players > Tools on the sidebar.
4. Under the Downloads section of this page, you’ll find your JW Player 7
(Self-Hosted) License Key. Copy the License Key.

5. Go back to WordPress and click on Video Gallery > Video
Player Settings.
6. Paste your License Key into the JWPlayer License Key box.
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7. Click Save Player Settings.

6b. Creating a Video Gallery
1. Now you’re ready to create a Video Gallery. Click on Video Gallery > Add Gallery /
Videos.
2. Fill out the New Gallery field with a title and the Description field with a description.

3. Click Add Gallery.
4. Click Add Media.

5. Select whichever video you want to add into your Video Gallery.
6. Click Into and select the name of your Video Gallery.
7. Click Add Media.
8. Repeat this until you have added all of the video files you want into your Video Gallery.

6c. Managing your Video Gallery
1. Click on Video Gallery > Manage Gallery.
2. You will see your Video Gallery listed, click on its title.
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3. On this page, you can edit the title/description of your Video Gallery, and can also edit
details for the videos you’ve included in the Video Gallery.
4. Scroll over the video to Upload Preview Image, which will become the video’s
thumbnail.

5. Add a title and description for your videos.
6. Once you are finished, click Save Changes.

6d. Embedding your Video Gallery
1. You are now ready to embed your Video Gallery into a page. Navigate to the page where
you would like to host your Video Gallery.
2. Under the Visual toolbar, there is a green icon that will say Cool Video Gallery Toolbar
when hovered over. Click the green icon.

3. You want your Video Gallery to appear as a Showcase, Slideshow, or Playlist. Test out
all of the options to decide what looks best on your website.

4. Click Generate.
5. Click Copy to Clipboard.
www.socialanthropology.org
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6. Paste the newly generated shortcode onto your page.
7. Click the Preview button on the right to preview how your Video Gallery
is going to look on your page. It will open up a new window to show you.
Every page will look different, depending on how it is customized.

6. Go back to the previous window where you can edit your page. If you like
the way the Video Gallery/page looks and you’re ready to make it public
on your website, click the Publish button. If not, you can always click
the Save Draft button to save your progress and come back later.

TIPS:
Test out all of the different features that the Video Gallery plugin has, including different
ways of displaying video galleries, different skins for the video player (under Video
Gallery > Video Player Settings) and more to find what looks best on your page.
Hosting your videos on your WordPress Media Library isn’t the best option, as there
there can be issues with server bandwidth, file size limits, slower loading videos, etc. The
most suitable option would be to host them on a video sharing website (such as
Youtube), and embed them through there.
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7. Exporting Content & Metadata
Downloading media content with attached metadata
WordPress is a great space to host and share content, but if you want to have a backup the
website’s files on your own computer with the attached metadata, this is how to do so.

7a. Exporting the media content from WordPress to your
computer
1. Click on Media > Download Media Library.
2. Under “Choose the post types”, the only box that should be clicked is
Media.
3. Under “and/or choose the mime types”, check all available options.
4. Click Download .zip.
5. A .zip file will be downloaded to your computer with all of your
multimedia content included.
6. Drag this into the folder entitled MEDIA, which was
downloaded in Section 2d.

7b. Exporting the metadata content from WordPress to
your computer
1. Click on Tools > Export.
2. Under “Choose what to export”, verify that All Content has been selected.
3. Click Download Export File.
4. An .xml file will be downloaded to your computer.
5. Rename this .xml file to media.xml.
6. Drag this file into the folder entitled MEDIA,
which was downloaded in Section 2d.
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7c. Extracting the metadata content from the XML file into a readable
Excel file
1. You should now have a folder on your desktop called MEDIA, with media.py,
media.xlsx, media.xml and the .zip file from Section 7a inside of it.

2. In the media.xlsx file, there are headers that have already been named. The only
headers you should overwrite are the ones that say ADDITIONAL METADATA
FIELD, which should be replaced with the names of your custom metadata fields.
Change those headers to the names of the metadata fields that you created in Section 4c.
If you have forgotten the names of your metadata fields, you can find them in Settings >
Media Library Assistant > Custom Fields. For example, if you created metadata
fields called “File Name”, “Date”, “Photographer”, and “Copyright”, your spreadsheet
would look like:

Make sure that your headers in the media.xlsx file are the exact same as the
ones on WordPress, i.e. verify that the capitalization is the same: if it is location on
WordPress, then it needs to be location in your file. If it is Location on WordPress, then it
needs to be Location in your file.
3. Once your changes are made, Save your Excel document.
If you are on a Mac, continue to Section 7D.
If you are on a PC, continue to Section 7E.
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7d. Extracting the metadata content from the XML file into a
readable Excel file (MAC VERSION)
1. Open the application Terminal (this is automatically included on all Mac computers).
2. Type the following commands and then hit the enter button on
your keyboard (do not type enter):
cd desktop/MEDIA
(enter)
sudo easy_install pip
(enter)
[Here you will be prompted to enter your computer’s password, if it has
one. Type your computer’s password, then hit the enter button]
[The script will run and text will appear on the Terminal screen. This is
normal, do not worry]
(enter)
sudo pip install unicodecsv
(enter)
sudo pip install xml.etree.ElementTree
(enter)
sudo pip install openpyxl
(enter)
python media.py media.xml media.xlsx
3. After entering the last command, the file media.csv will be created within the MEDIA
folder. It lists the information included under each section that you put in the media.xlsx
header (i.e. “name”, “date”, “photographer” and “copyright”) .
You are now able to cross-reference your downloaded media content (7a) with your metadata
information (7b and 7c).
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7e. Extracting the metadata content from the XML file into a readable
Excel file (PC VERSION)
The process above is slightly more complex on a PC, and so we suggest that, if possible, you
try and use a Mac for this section, or request assistance from someone with IT experience.
1. Download and install Python (see 2d for set-up instructions).
2. In your Windows Start Menu, type
environment variables, then hit
enter.
3. In the new pop-up window, scroll down
to where it says Path in the Variable
column, highlight it, and hit the Edit
button.
4. Paste ;C:\Python37\;C:\Python37\Scripts onto the end of the Variable Value
textfield (if a mistake is made, hit Cancel and open the window again).
5. Open Command Prompt (this is automatically included on all PC computers).

6. Type the following commands and then hit enter:
cd desktop/media
(enter)
easy_install pip
(enter)
pip install unicodecsv
(enter)
pip install xml.etree.ElementTree
(enter)
pip install openpyxl
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(enter)
python media.py media.xml media.xlsx
7. After entering the last command, the file
media.csv will be created within the MEDIA
folder. It lists the information included under
each section that you put in the media.xlsx
header (i.e. “name”, “date”, “photographer” and
“copyright”).
You are now able to cross-reference your
downloaded media content (7a) with your metadata information (7b and 7c).
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